
TSMWin32
Telecom Synchronization Monitor for
Windows 95/98/NT®

User Guide

P/N 12778458-002-2, Rev. F
Austron/Datum

April 1999
Serial No. Prefix: 990705398

For 24-hour customer service, contact Austron, Inc.
Address: P.O. Box 14766, Austin, Texas 78761
Shipping Address: 15811 Vision Drive, Pflugerville, Texas 79660
Phone: 512.721.4032 ! Fax: 512.251.9685 ! Web: www.datum.com





NOTICE
AUSTRON, Inc. provides this manual “as is” without warranty  of any  kind, either expressed or implied, including, but not
limited to the implied warranties of merchantability  and fitness for a particular purpose. AUSTRON may  make improvements
and or change in the product(s) and or the program(s) described in this manual at any  time and without notice.

This publication could contain technical inaccuracies or typographical errors. Changes are periodically  made to the information
herein; these changes will be incorporated in new editions of this publication.

A Reader's Comment Form is provided at the back of this publication. If this form has been removed, address comments to:

AUSTRON, Inc.
P. O. Box 14766
Austin, Texas 78761

AUSTRON may  use or distribute any  of the information you supply  in any  way  it believes appropriate without incurring any
obligations whatever.

© Copyright AUSTRON, Inc. 1996–97. All rights reserved. Printed in U.S.A.

The information and/or drawings set forth in this document and all rights in and to inventions disclosed herein which might be
granted thereon disclosing or employ ing the materials, methods, techniques or apparatus described herein, are the exclusive
property  of AUSTRON, Inc.

WARRANTY
AUSTRON, Inc. of Austin, Texas, warrants for one year after delivery  to the original purchaser of any  product manufactured by
AUSTRON, that same shall be free of defects in material and workmanship. Obligation under this warranty  shall be limited to
repair or replacement, at AUSTRON's discretion, of any  product or part thereof which has been returned by  the original
purchaser with transportation prepaid, and upon examination by  AUSTRON, is found to be defective. AUSTRON assumes no
responsibility  for loss or damage to equipment being returned for repair or replacement under the terms of this warranty .

For this warranty  to be effective, the purchaser agrees that the equipment will be properly  installed and maintained. Equipment
which, upon examination by  AUSTRON, requires repair or replacement of parts thereof as a result of improper installation,
misuse, unauthorized alterations or repairs, or user negligence, such repairs or replacement of parts thereof will be made at cost.

AUSTRON makes no representation or warranty  of any  kind, either expressed or implied, with respect to equipment operation
and procedures. Any  action that the user may  take in reliance upon the operation or accuracy  of this equipment shall be taken
solely  upon the user's own responsibility  and risk.

AUSTRON shall not be liable for consequential damages to purchaser, user, or any  others resulting from the possession or use of
this equipment.

Prior to return of a product under terms of this warranty , AUSTRON, Inc., Austin, Texas, is to be notified. Notification is to
include the model number and serial number of the product and full details of the problem.

TRADEMARK NOTICE
TSMWin32 and Austron Model 3800 Timing Signal Generator are registered trademarks of Austron, Inc.

Windows 95, Windows 98, and Windows NT are registered trademarks of Microsoft Corporation.

IBM is a registered trademark of International Business Machines Corporation.

Ethernet is a registered trademark of Xerox Corp.

AMENDMENT NOTICE
AUSTRON, Inc. makes every  attempt to provide up-to-date manuals with the associated equipment. Occasionally , changes are
made to the equipment wherein it is necessary  to provide amendments to the manual. If any  amendments are provided for this
manual they  are printed on paper stock other than white and will be found at the rear of this manual.

"  
Note

The contents of any  amendments may  affect operation and/or maintenance of the
equipment





12778458-002-2 Rev. F ▼▼▼▼ D ATUM-Austron

TSMW in32 User Guide Contents ▲▲▲▲ i

Contents

1 Introducing TSMWin32 .............................................................................................. 1-1

1.1 In This Chapter . . ................................................................................................ 1-1

1.2 TSMWin32 Overview ........................................................................................... 1-1

1.3 Hardware and Software Requirements ...................................................................... 1-2

1.4 What's New in TSMWin32 .................................................................................... 1-2

1.5 Using This User Guide.......................................................................................... 1-2
1.5.1 Where to Start ......................................................................................... 1-2
1.5.2 How This User Guide is Organized.............................................................. 1-3
1.5.3 Typestyles and Conventions Used in This User Guide..................................... 1-3

1.6 Getting Help........................................................................................................ 1-3

1.7 Installing and Running TSMWin32 ......................................................................... 1-3
1.7.1 Installing TSMWin32 ............................................................................... 1-3
1.7.2 Important Note About Upgrading from Earlier Versions................................... 1-3
1.7.3 Running TSMWin32 ................................................................................ 1-6

2 Using TSMWin32...................................................................................................... 2-1

2.1 In This Chapter . . ................................................................................................ 2-1

2.2 Running TSMWin32 for the First Time.................................................................... 2-1

2.3 The TSMWin32 User Interface................................................................................ 2-2
2.3.1 The TSMWin32 Window .......................................................................... 2-2
2.3.2 Toolbar .................................................................................................. 2-2
2.3.3 Menu Bar................................................................................................ 2-3
2.3.4 General Graphing Instructions..................................................................... 2-3
2.3.5 Naming Conventions ................................................................................ 2-5
2.3.6 File Menu............................................................................................... 2-5
2.3.7 Graph Menu ............................................................................................ 2-8
2.3.8 View Menu ........................................................................................... 2-17
2.3.9 Setup Menu........................................................................................... 2-19
2.3.10 Help Menu............................................................................................ 2-28

3 Using AusGraph to View Outputs ................................................................................. 3-1

3.1 In This Chapter . . ................................................................................................ 3-1

3.2 Overview of AusGraph and TSMWin32 Outputs........................................................ 3-1
3.2.1 Launching AusGraph................................................................................. 3-1

3.3 AusGraph Menus.................................................................................................. 3-2
3.3.1 Graph Menu ............................................................................................ 3-2



12778458-002-2 Rev. F ▼▼▼▼ D ATUM-Austron

ii ▲▲▲▲ Contents TSMW in32 User Guide

3.3.2 View Menu ............................................................................................. 3-3
3.3.3 Scale Menu ............................................................................................. 3-4

4 Communications Ports and Modem Setup....................................................................... 4-1

4.1 In This Chapter . . ................................................................................................ 4-1

4.2 Setting Up TSG Communications Ports .................................................................... 4-1

4.3 Setting Up Modems.............................................................................................. 4-2

4.4 Estimating Hard Disk Space for 30 days of Data......................................................... 4-2
5 Glossary of Terms ...................................................................................................... 4-1



12778458-002-2 Rev. F ▼▼▼▼ D ATUM-Austron

TSMW in32 User Guide Introducing TSMW in32 ▲▲▲▲ 1-1

1 Introducing TSMWin32

1.1 In This Chapter . . .
! TSMWin32 Overview

! Hardware and Software Requirements

! What's New in TSMWin32

! Installing and Running TSMWin32

! Using This User Guide

! Getting Help

1.2 TSMWin32 Overview
The Telecom Synchronization Monitor for Windows 95/98/NT® software, TSMWin32, is a
Microsoft Windows® 95/98/NT® program. TSMWin32 provides synchronization
performance monitoring of single or multiple local or remote Austron Model 3800 Timing
Signal Generators (TSGs) running Rev. C.## or later firmware.

TSMWin32 provides serial port communications via direct connection, modem, and X.25
networks as well as Ethernet® connections to multiple TSGs, providing a communications
interface for collecting phase, frequency, historical MTIE, 24 hr MTIE, TDEV, event, and
alarm data from each connect ed TSG, and for storing the data on the hard disk of a computer.

Note: Your hardware and operating system configuration determine the maximum number of
serial ports that you can use.

You perform TSMWin32 operations by choosing commands from the menus, clicking toolbar
buttons, and selecting program and TSG configuration options in dialog boxes.

Menu commands allow you to perform all TSMWin32 functions, including:

•  Start scanning (Paragraph 2.3.6.2) or stop scanning (Paragraph 2.3.6.3).

•  Use terminal mode to communicate with connected instruments (Paragraph 2.3.6.1).

•  Graph data:

•  Phase data (Paragraph 2.3.7.1).

•  24-hour MTIE data (Paragraph 2.3.7.2).

•  TDEV data (Paragraph 2.3.7.3).
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•  Frequency data (Paragraph 2.3.7.4).

•  Historical MTIE data (Paragraph 2.3.7.3).

•  View last data gathered (Paragraph 2.3.8.1).

•  View events (Paragraph 2.3.8.2).

•  View incoming alarm conditions and notifications of new alarms (Paragraph 2.3.1)

•  Clear alarm messages (Paragraph 2.3.8.3) or status messages (Paragraph 2.3.8.4).

•  Configure TSMWin32 (Paragraph 2.3.9).

•  Configure one or more TSGs (Paragraph 2.3.9.2).

TSMWin32 automatically applies and saves to the computer hard disk any changes that you
make to the system configuration.

1.3 Hardware and Software Requirements
Before installing TSMWin32, verify that your system configuration meets these minimum
hardware and software requirements:

•  IBM PC-compatible computer with at least 16 MB of RAM.

•  Operating System: Windows 95, Windows 98, or Windows NT 4.0.

•  NE: TSG 3800 Revision C or Higher software

•  NE Interface: TCP/IP, Modem, X.25 PAD or Direct Serial Port.

1.4 What's New in TSMWin32
TSMWin32 has these additional features:

•  Direct TCP/IP connections to instruments.

•  MTIE and TDEV data collection on Single Port and Three Port Input Modules.

•  Improved user interface.

•  Improved data base handling.

•  Improved performance.

1.5 Using This User Guide
We have designed this User Guide for you to use as an installation guide, a procedural
manual, and general reference to TSMWin32.

1.5.1 Where to Start

•  If you are installing TSMWin32, see the installation instructions on page 2-2.

•  If you are a first time user, you should read all the chapters in this User Guide.

•  If you are an experienced TSMWin32 user, you should read "What's New in
TSMWin32" on page 2-2, and "Using TSMWin32" on page 2-1.
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1.5.2 How This User Guide is Organized

•  1: Error! Reference source not found.: This chapter provides a general description
of the software, hardware and software requirements for installing and running
TSMWin32, and installation instructions.

•  2: Using TSMWin32: This chapter describes menu commands, toolbar buttons, and
dialog box options, configuring data gathering and connection settings.

•  3: Using AusGraph to View Outputs: This chapter describes using AusGraph to
configure TSMWin32 graph outputs.

•  4: Communications Ports and Modem Setup: This chapter provides information
about TSG communications port and modem settings.

•  Error! Reference source not found.: This section provides definitions for
terminology used in this User Guide.

1.5.3 Typestyles and Conventions Used in This User Guide

This Users Guide uses different styles of text to help identify kinds of information.

•  Interface object names are italic:
The Graph menu . . .
The Frequency toolbar button . . .

•  File names are italic (in roman text) or roman (in italic text) and capitals:
STARTUP.EXE
TSMWin32.CFG
01_1-1_PHAS.111

•  Keyboard keys and key combinations are initial capitals and small capitals:
Press CTRL + P

1.6 Getting Help
In addition to the information found in this User Guide, TSMWin32 Help is available. To
view the TSMWin32 Help Contents topic, click the Help toolbar button or choose Help
Topics from the Help menu. For more information about using the TSMWin32 Help, see page
2-28.

1.7 Installing and Running TSMWin32

1.7.1 Installing TSMWin32

TSMWin32 is fast and easy to install. The installation media consists of two diskettes, labeled
"Disk 1" and "Disk 2." The installation process makes use of an "install wizard" to automate
installation procedures.

1.7.2 Important Note About Upgrading from Earlier Versions

This version of TSMWin32 is not "backward compatible" with earlier versions of TSMWin32
software. For this reason: (a) uninstall any earlier versions of the software before installing
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this version of TSMWin32; (b) after uninstalling, be sure to delete the folders and files
TSMWin32 uses for storing data and configuration files; (3)do not overwrite existing
installations of TSMWin32 software with TSMWin32 files.

1.7.2.1 Uninstalling Previous Versions of TSMWin32

To uninstall previous versions of TSMWin32:

•  From the Windows Start menu, open the Control Panel: Click Start > Settings >
Control Panel.

•  In the Control Panel, double-click the Add/Remove Programs icon (Figure 1- 1).

Figure 1- 1. Selecting the Add/Remove Programs icon in Control Panel

•  In the Add/Remove Programs properties sheet:

•  Click the Install/Uninstall tab.

•  Select the TSMWin32 program name from the list.

•  Click Add/Remove to remove TSMWin32 program files. When the files
have been removed, click OK to close the dialog box.

1.7.2.2 Removing Data and Configuration Files

To remove TSMWin32 data and configuration files created by earlier versions of TSMWin32:

•  In Windows Explorer, navigate to the folders containing TSMWin32 data and
configuration files.

•  Select and delete the folders.

TSMWin32 creates new data and configuration folders and files when you run it the first
time.

1.7.2.3  Installing TSMWin32

To install TSMWin32:

1. Place Disk 1 in your diskette drive (Drive A: or Drive B:).

2. Run the SETUP program using one of these methods:
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•  From the Start menu, click Run to open the Run dialog box (Figure 1- 2). In
the Open: text box, type the path and filename to the SETUP.EXE file (or
click the Browse button to navigate to and select the SETUP.EXE file).

Figure 1- 2. Windows Run dialog box

•  In the Windows Explorer window, navigate to the diskette drive. Double-
click the SETUP executable icon to start the setup program (Figure 1- 3).

Figure 1- 3. The Setup Program

3. The setup program runs the TSMWin32 installation "wizard" (Figure 1- 4). Follow
the instructions or answer the questions presented in the wizard: click the navigation
buttons to navigate forward or backward in the wizard (or click Cancel to close the
wizard and exit the setup program).

Figure 1- 4. TSMWin32 Setup Program Wizard (1)

4. The setup program creates some of the necessary folders, a program group, and an
icon for TSMWin32. The setup program creat es default folders in the Program Files
folder of your file system. Alternately, you can select a different folder or creat e a
new folder for the program files by clicking Browse and selecting a folder location or
creating a new folder.
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Figure 1- 5. TSMWin32 Setup Program Wizard (2)

5. TSMWin32 configuration and data folders will be created when you run the software
the first time (see Paragraph 2.2).

1.7.3 Running TSMWin32

To run TSMWin32:

1. From the Start/Programs menu, click the TSMWin32 icon (or double-click the
TSMWin32 icon in the Windows Explorer or on the desktop).

2. TSMWin32 starts, displaying the main window (Figure 1- 6).

Figure 1- 6. The TSMWin32 main window

Note: The first time you run TSMWin32, the program notifies you that it must create
additional folders. Select OK when asked if these folders (directori es) should be created. For
more information, see "Running TSMWin32 for the First Time" on page 2-1.
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2 Using TSMWin32

2.1 In This Chapter . . .

! Running TSMWin32 for the First Time

! The TSMWin32 User Interface

2.2 Running TSMWin32 for the First Time
When you run TSMWin32 for the first time, the program offers to create a folder for the
configuration file (Figure 2- 1), and an initial configuration file (Figure 2- 2) containing
default values.

•  To allow TSMWin32 to create the configuration folder, click Yes in the dialog box
(Figure 2- 1).

Figure 2- 1. Confirmation dialog box for creating TSMWin32 configuration folder CONFIG

•  To allow TSMWin32 to create the configuration file and place it in the configuration
folder, click OK (Figure 2- 2).

Figure 2- 2. Confirmation dialog boxes for creating TSMWin32 configuration file TSMWin32.CFG

TSMWin32 opens, displaying the main window (Figure 2- 3).
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Figure 2- 3. The TSMWin32 window

2.3 The TSMWin32 User Interface

2.3.1 The TSMWin32 Window

When you start TSMWin32, you see the TSMWin32 main window (Figure 2- 3). This
window consists of standard menu bar, tool bar, Alarm Window, System Status Window, and
status bar.

•  Click a menu title to display menu commands. Click a menu command to execute the
command.

•  Click a toolbar button to execute the command. The most frequently used menu
commands are duplicated on the TSMWin32 toolbar.

The main window is divided into two areas:

•  The top area or pane is called the Alarm Window and displays TSMWin32 alarm
messages.

•  The bottom pane is called the System Status Window and displays system
information and data.

2.3.2 Toolbar

TSMWin32 provides one-click access to the most frequently used commands on a toolbar
(Figure 2- 4).
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Figure 2- 4. TSMWin32 toolbar

2.3.3 Menu Bar

All of the TSMWin32 commands are available on the menus. The topics that follow provide a
description of each menu title and its commands.

2.3.4 General Graphing Instructions

Each Graph menu command opens a data selection dialog for the data type.

For each data type that you want to graph, select the TSG(s) and input(s) to be plotted, and
speci fy the input(s) and time period (duration) to use in plotting the data.

2.3.4.1 To Select Data to Graph

To select the data to graph:

•  Choose the data type from the Graph menu (or click the toolbar button) to open the
Select Data for . . . Graph dialog.

•  In the Data To Graph area: click the TSG list to display the list of TSGs.

•  Click a TSG on the list to select it. You can graph data for any defined TSG. For
more information about defining TSGs, see Paragraph 2.3.9.2.

•  Click the Input list to display a list of the available inputs, then click an input on the
list to select it. You can graph data for up to eight inputs (choosing from up to 12
available inputs) on a single graph. For more information about enabling and naming
inputs, see Paragraph 2.3.9.2.

2.3.4.2 To Add or Remove Graph Inputs

To add or remove inputs from the list of inputs to graph:

•  Choose the data type from the Graph menu (or click the toolbar button) to open the
Select Data for . . . Graph dialog.

•  Click the Add button (in the center of the dialog box) to add the selected data to the
Input(s) to Graph list.

•  Select an input in the Input(s) to Graph list; then click the Remove button (in the
center of the dialog box) to remove the input from the list.

2.3.4.3 To Remove All Graph Inputs

To remove all graph inputs:

•  Choose the data type from the Graph menu (or click the toolbar button) to open the
Select Data for . . . Graph dialog.
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•  Click the Remove All button (in the center of the dialog box) to remove all inputs
from the Input(s) To Graph list.

2.3.4.4 To Specify Graph Input Time Ranges

To specify the duration for the graph information:

•  Choose the data type from the Graph menu (or click the toolbar button) to open the
Select Data for . . . Graph dialog.

•  Set Duration options (at the bottom of the dialog box). Enter all times in military
format (02:00, 23:00, etc.).

•  Start Date: Enter the beginning date for the graph data.

•  Start Time: Enter the starting time for the graph data when graphing a
portion of the data for a single day. This is useful for trouble shooting or
when you are trying to zoom in on a suspected problem area.

•  Stop Date: Enter the ending date for the graph data.

•  Stop Time: Enter the Stop Time for the data graph. Enter the ending time for
the graph data when graphing a portion of the data for a single day. This is
useful for trouble shooting or when you are trying to zoom in on a
suspected problem area.

2.3.4.5 To Specify Performance Mask Values

For MTIE and TDEV graphs, you can specify and configure a performance mask to be used
in the graph:

•  Click Edit Mask to open the performance mask dialog; enter the performance values;
click OK to save the values (or click Cancel to close the dialog without saving the
values).

•  Mark the Include Mask check box to add performance mask values to the graph.

2.3.4.6 To Display a Graph of the Selected Inputs

To launch AusGraph and display the selected data as graph:

•  Click Graph to graph the selected data for the speci fied duration (or click Cancel to
close the dialog box without saving the graph settings).

Note: If a data file required for graphing the selected TSGs and inputs is not available, most
likely because the speci fied data has not been scanned, one more more File Error
messages(Figure 2- 5) describes the file(s ) that cannot be found. If there is suffi cient available
data to compose the graph, AusGraph displays the graph.

Figure 2- 5. File Error message
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2.3.5 Naming Conventions

TSMWin32 uses these conventions for naming TSG, input, and data files:

•  When you create a new TSG, TSMWin32 assigns a default name and the next
available number: for example, TSG 2.

•  Input names indicate the input card number, and a port number for that input card:
for example, Inp1.1 indicates input card 1, port 1; Inp2.2 indicates input card 2, port
2; and so on.

•  Data file names indicate the TSG number, input card/port number, and data type: for
example, 02_1-1_PHAS indicates a file containing phase data collected from TSG 2,
input card 1, port #1.

•  Data file type names used for naming data files are: PHAS (phase data), MTIE
(Historical MTIE data), FREQ (frequency data), TDEV (TDEV data), and RLMT
(24 hr [real] MTIE data).

2.3.6 File Menu

Use the commands on the File menu to connect via a terminal, to start or stop scanning, or to
exit TSMWin32.

2.3.6.1 Terminal

Choose Terminal on the File menu (or click the Terminal toolbar button   ) to open the

Terminal window (Figure 2- 6). Use this window to select a TSG, connect or disconnect to a
TSG via a terminal, and to configure TSG settings such as MTIE Alarm Thresholds.

Figure 2- 6. Terminal dialog
showing TCP/IP connection
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To connect to a TSG using the terminal mode:

1. Click the TSG list and select the defined TSG to which you want to connect.

2. Click the Connect button to start the connection. For network connections requiring a
login name and password, the network or instrument to which you are trying to
connect prompts you to enter each (Figure 2- 7).

Figure 2- 7. T erminal window
example of login prompt and response

3. To end the connection, click Disconnect.

4. Select another TSG, if necessary.

5. When you are finished making terminal connections, click Disconnect to end the
connection, then click Done to close the Terminal window.

2.3.6.2 Scan Now . . .

Choose Scan Now on the File menu (or click the Scan toolbar button   ) to establish the

connection and begin data gathering ("scanning") from all defined TSGs. The Scan toolbar
button turns scanning on when the button appears pressed, or off when the button appears
unpressed.
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Figure 2- 8. TSMWin32 main window
showing scanning information in the System Status window ( lower pane of main window)

For information about defining TSGs, see Paragraph 2.3.9.2.

After connecting to the selected TSG, TSMWin32 performs the tasks speci fied in the
configuration file and any new settings that you have speci fied in the General Setup and TSG
Setup dialog boxes.

2.3.6.3 Stop Scan

Choose Stop Scan on the File menu to stop data gathering from all defined TSGs. The Scan
toolbar button "toggles" scanning: scanning is turned off when the button appears unpressed
or raised.

For information about defining TSGs, see Paragraph 2.3.9.2.

2.3.6.4 Exit

Choose Exit from the File menu to stop all monitoring and data gathering and close
TSMWin32.

Note: Data gathering occurs only while TSMWin32 is running.

2.3.7 Graph Menu
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Use the commands on the Graph menu to specify the TSG and input data, starting and ending
date and time, and other information to be displayed as a graph. Click Graph in any data
selection dialog to launch AusGraph and display the selected data. AusGraph offers many
options for configuring the appearance and behavior of graphs or printing graph information.

2.3.7.1 Phase

Choose Phase from the Graph menu (or click the Phase toolbar button  ) to open the
Select data for Phase Graph dialog box (Figure 2- 9). Use the options in this dialog to select
TSGs and inputs to graph, and use the resulting phase data graph to monitor line quality
throughout the user network.

•  Select the phase data to graph. In the Data To Graph area:

•  Click the TSG list to display the list of TSGs. Click a TSG on the list to
select it. You can graph phase data for any defined TSG. For information
about defining TSGs, see Paragraph 2.3.9.2.

•  Click the Input list to display a list of the available inputs. Click an input on
the list to select it. You can graph phase data for up to eight inputs
(choosing from up to 12 available inputs) on a single graph. For information
about enabling and naming inputs, see Paragraph 2.3.9.1.

Figure 2- 9. Select data for Phase Graph dialog box

•  To add or remove inputs:

•  Click the Add button (in the center of the dialog box) to add the selected
phase data to the Input(s) to Graph list.

•  Select an input in the Input(s) to Graph list; click the Remove button (in the
center of the dialog box) to remove the input from the list.

•  Click the Remove All button (in the center of the dialog box) to remove all
inputs from the Input(s) To Graph list.

•  Set Duration options (at the bottom of the dialog box):
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•  Start Date: Edit the Start Date for phase data graph.

•  Start Time: Edit the Start Time for the phase data graph.

•  Stop Date: Edit the Stop Data for the phase data graph.

•  Stop Time: Edit the Stop Time for the phase data graph.

•  Graph: Click Graph to graph the selected data for the speci fied duration (or click
Cancel) to close the dialog box without saving the phase graph settings).

The phase data graph (Figure 2- 10) displays the selected data in this format:

Figure 2- 10. Phase data graph

•  Y-axis displays phase data, scaled in nanoseconds or unit intervals (DS1 UI = 648 nS
and E1 UI = 488 nS).

•  X-axis displays the time period specifi ed.

•  Legends identify each input represented on the graph.

If the requested data does not exist, TSMWin32 displays an error message.

2.3.7.2 24 hr MTIE . . .

Choose 24 hr MTIE from the Graph menu (or click the 24 hr MTIE toolbar button  ) to

open the Select data for 24 hr MTIE Graph dialog box (Figure 2- 11).

Use the options in the dialog box to specify the data constraints to be used in plotting a
log/log graph of 24 hr MTIE data.

•  Select the 24 hr MTIE data to graph. In the Data To Graph area:

•  Click the TSG list to display the list of TSGs. Click a TSG on the list to
select it. You can graph 24 hr MTIE data for any defined TSG. For
information about defining TSGs, see Paragraph 2.3.9.2.

•  Click the Input list to display a list of the available inputs. Click an input on
the list to select it. You can graph 24 hr MTIE data for up to eight inputs
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(choosing from up to 12 available inputs) on a single graph. For information
about enabling and naming inputs, see Paragraph 2.3.9.1.

Figure 2- 11. Select data for 24 hr MT IE Graph dialog box

•  To add or remove inputs:

•  Click the Add button (in the center of the dialog box) to add the selected 24
hr MTIE data to the Input(s) to Graph list.

•  Select an input in the Input(s) to Graph list; click the Remove button (in the
center of the dialog box) to remove the input from the list.

•  Click the Remove All button (in the center of the dialog box) to remove all
inputs from the Input(s) To Graph list.

•  Edit Mask: To define a 24 hr MTIE performance mask, click Edit Mask to open the
MTIE Mask dialog (Figure 2- 12) and specify performance mask values:

1. Enter values for the performance mask.

2. Mark the Save Mask check box to save the values as part of the TSMWin32
configuration (i f you do not mark Save Mask, TSMWin32 applies the
values when displaying the MTIE data, but does not include the mask in the
TSMWin32 configuration).

3. Click OK to save the performance mask values (or click Cancel to close the
dialog without saving performance mask values).
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Figure 2- 12. MTIE Mask dialog box

•  Include Mask: Mark the check box to use the performance mask in the display of the
24 hr MTIE data graph.

Figure 2- 13. 24 hr MTIE data plot

•  Stop Date: Set Stop Date for 24 hr MTIE data.

•  Graph: Click Graph to graph the selected data for the speci fied duration (or click
Cancel) to close the dialog box without saving the 24 hr MTIE graph settings).

The 24 hr MTIE data graph (Figure 2- 13) displays the selected data in this format:

•  Y-axis displays MTIE data, scaled in nanoseconds.

•  X-axis displays the time period specifi ed.

•  Legends identify each input represented on the graph.

If the requested data does not exist, TSMWin32 displays an error message.
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2.3.7.3 TDEV

Choose TDEV from the Graph menu (or click the TDEV toolbar button  ) to open the
Select data for TDEV Graph dialog box (Figure 2- 14).

Figure 2- 14. Select data for TDEV Graph dialog box

Use the options in the dialog box to specify the data constraints to be used in plotting a
log/log graph of TDEV data.

•  Select the TDEV data to graph. In the Data To Graph area:

•  Click the TSG list to display the list of TSGs. Click a TSG on the list to
select it. You can graph TDEV data for any defined TSG. For information
about defining TSGs, see Paragraph 2.3.9.2.

•  Click the Input list to display a list of the available inputs. Click an input on
the list to select it. You can graph TDEV data for up to eight inputs
(choosing from up to 12 inputs) on a single graph. For information about
enabling and naming inputs, see Paragraph 2.3.9.1.

•  To add or remove inputs:

•  Click the Add button (in the center of the dialog box) to add the selected
TDEV data to the Input(s) to Graph list.

•  Select an input in the Input(s) to Graph list; click the Remove button (in the
center of the dialog box) to remove the input from the list.

•  Click the Remove All button (in the center of the dialog box) to remove all
inputs from the Input(s) To Graph list.

•  Edit Mask: To define a TDEV performance mask, click Edit Mask to open the TDEV
Mask dialog (Figure 2- 12) and specify performance mask values:
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Figure 2- 15. TDEV Mask dialog box

1. Enter values for the performance mask.

2. Mark the Save Mask check box to save the values as part of the TSMWin32
configuration (i f you do not mark Save Mask, TSMWin32 applies the
values when displaying the TDEV data, but does not include the mask in
the TSMWin32 configuration).

3. Click OK to save the performance mask values (or click Cancel to close the
dialog without saving performance mask values).

•  Include Mask: Mark the check box to use the performance mask in the display of the
TDEV data graph.

•  Stop Data: Set Stop Date for TDEV data.

•  Graph: Click Graph to graph the selected data for the speci fied duration (or click
Cancel) to close the dialog box without saving the TDEV graph settings).

The TDEV data graph (Figure 2- 16) displays the selected data in this format:
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Figure 2- 16. TDEV data plot

•  Y-axis displays TDEV data, scaled in nanoseconds.

•  X-axis displays the time period specifi ed.

•  Legends identify each input represented on the graph.

If the requested data does not exist, TSMWin32 displays an error message.

2.3.7.4 Frequency

Choose Frequency from the Graph menu (or click the Frequency toolbar button  ) to

open the Select data for Frequency Graph dialog box (Figure 2- 18).

Figure 2- 17. Frequency data plot
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Use the options in the dialog box to specify the data constraints to be used in plotting a linear
graph of frequency data.

•  Select the data to graph. In the Data To Graph area:

•  Click the TSG list to display the list of TSGs. Click a TSG on the list to
select it. You can graph frequency data for any defined TSG. For
information about defining TSGs, see Paragraph 2.3.9.2.

•  Click the Input list to display a list of the available inputs. Click an input on
the list to select it. You can graph frequency data for up to eight inputs
(choosing from up to 12 available inputs) on a single graph. For information
about enabling and naming inputs, see Paragraph 2.3.9.1.

•  To add or remove inputs:

•  Click the Add button (in the center of the dialog box) to add the selected
data to the Input(s) to Graph list.

•  Select an input in the Input(s) to Graph list; click the Remove button (in the
center of the dialog box) to remove the input from the list.

•  Click the Remove All button (in the center of the dialog box) to remove all
inputs from the Input(s) To Graph list.

Figure 2- 18. Select data for Frequency Graph dialog box

•  Set Duration options (at the bottom of the dialog box):

•  Start Date: Edit the Start Date for frequency data graph.

•  Start Time: Edit the Start Time for the frequency data graph.

•  Stop Date: Edit the Stop Data for the frequency data graph.

•  Stop Time: Edit the Stop Time for the frequency data graph.

•  Graph: Click Graph to graph the selected data for the speci fied duration (or click
Cancel) to close the dialog box without saving the frequency graph settings).
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The frequency data graph Figure 2- 17) displays the selected data in this format:

•  Y-axis displays the delta F/F data presented in picoseconds per second or
nanoseconds per second.

•  X-axis displays the time period specifi ed.

•  Legends identify each input represented on the graph.

If the requested data does not exist, TSMWin32 displays an error message.

2.3.7.5 Historical MTIE

Choose Historical MTIE from the Graph menu (or click the Historical MTIE toolbar

button  ) to open the Select data for Historical MTIE Graph dialog box (Figure 2- 19).

Figure 2- 19. Select data for historical MTIE Graph dialog box

Use the options in the dialog box to specify the data constraints to be used in plotting a linear
graph of historical MTIE data.

•  Select the data to graph. In the Data To Graph area:

•  Click the TSG list to display the list of TSGs. Click a TSG on the list to
select it. You can graph historical MTIE data for any defined TSG. For
information about defining TSGs, see Paragraph 2.3.9.2.

•  Click the Input list to display a list of the available inputs. Click an input on
the list to select it. You can graph historical MTIE data for up to eight
inputs (choosing from up to 12 available inputs) on a single graph. For
information about enabling and naming inputs, see Paragraph 2.3.9.1.

•  To add or remove inputs:

•  Click the Add button (in the center of the dialog box) to add the selected
data to the Input(s) to Graph list.

•  Select an input in the Input(s) to Graph list; click the Remove button (in the
center of the dialog box) to remove the input from the list.
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•  Click the Remove All button (in the center of the dialog box) to remove all
inputs from the Input(s) To Graph list.

•  Set Duration options (at the bottom of the dialog box):

•  Start Date: Edit the Start Date for historical MTIE data graph.

•  Start Time: Edit the Start Time for the historical MTIE data graph.

•  Stop Date: Edit the Stop Data for the historical MTIE data graph.

•  Stop Time: Edit the Stop Time for the historical MTIE data graph.

•  Graph: Click Graph to graph the selected data for the speci fied duration (or click
Cancel) to close the dialog box without saving the historical MTIE graph settings).

The historical MTIE data graph (Figure 2- 20) displays the selected data in this format:

Figure 2- 20. Historical MTIE data plot

•  Y-axis displays MTIE data presented in nanoseconds.

•  X-axis displays the time period specifi ed.

•  Legends identify each input represented on the graph.

If the requested data does not exist, TSMWin32 displays an error message.

2.3.8 View Menu

Use the commands on the View menu to control the display of data in the main window.
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2.3.8.1 Last Data Gathered

Choose Last Data Gathered from the View menu to display Data Viewer window (Figure 2-
21). Choose a TSG from the TSG list to display the last measurements for phase, MTIE, and
frequency data for each enabled input.

Figure 2- 21. Data Viewer window
showing last data gathered for each input for the selected TSG

2.3.8.2 View Events

Choose View Event from the View menu to display the Event Viewer window (Figure 2- 22)
containing historical event data for the selected TSG.

TSMWin32 creates and stores an event file for each TSG connected to the system.

Figure 2- 22. Event Viewer window
showing history of events for the selected TSG

To filter event information, enter a search string in the Search For box, then click Search.
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2.3.8.3 Clear Alarm Messages

Choose Clear Alarm Messages from the View menu to remove all alarm and event messages
from the Alarm Window.

2.3.8.4 Clear Status M essages

Choose Clear Status Messages from the View menu to remove all connection status messages
from the System Status Window.

2.3.9 Setup Menu

Use commands on the Setup menu to configure TSMWin32 settings:

•  General . . . : Choose this command to view or set general system scanning,
repository, and terminal connection settings.

•  TSGs . . . : Choose this command to view or set TSG general, input, and connection
settings.

TSMWin32 stores all changes made to the General Setup and TSG Setup dialog box tab
options in memory while you are working in the program. When you exit TSMWin32, any
changes that you have made are automatically stored in the system configuration file. These
are the settings that are in effect when you restart TSMWin32.

2.3.9.1 General . . .

Choose General . . . on the Setup menu to open the General Setup dialog box (Figure 2- 23).
The tabs in this dialog box present options for defining how TSMWin32 scans connected
TSGs, where and for how long TSMWin32 saves scanned data, and how TSMWin32
connects to attached TSGs.

Figure 2- 23. General Setup dialog box
Scanning tab
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Click the tab title to bring the tab to the front of the dialog box.

To specify settings in the General Setup dialog box tabs:

•  Scanning: Click options on the Scanning tab of the General Setup dialog box (Figure
2- 23) to configure TSMWin32 scanning or view last scan time:

•  Auto-Scan Disabled: Select this option to disable the TSMWin32 Auto-
Scan feature and stop gathering data.

•  Scan every 1000 Seconds: Select this option to scan all connected TSGs
every 1000 seconds.

•  Scan every 1 hour: Select this option to scan all connected TSGs every
hour.

•  Scan every 12 hours: Select this option to scan all connected TSGs every 12
hours. The scan time is be based on the last scan time.

•  Scan at (time): Select this option and select a time for scanning all
connect ed TSGs. TSMWin32 scans twice a day on this hour. For example,
enter 6:00 to scan at 6:00 a.m. and 6:00 p.m.

•  Scan continuously: Select this option to scan all connected TSGs
continuously, i.e., automatically begin a new scan sequence immediately
upon completion of the current scan sequence. When you set continuous
scanning with this option, you must select Auto-Scan Disabled during the
pause between scans to disable the next scan.

•  Last scan at (time): TWMWin32 displays the time and date of the last scan.

Note: There are several considerations that can help determine how oft en
the system should be set to collect data.

1. The number of TSGs connected to the system: For systems with
more than 20 TSGs connected to the system, we suggest setting a
12 Hour or Scan at [hour] rate. This allows for data gathering from
all TSGs.

2. Importance of Event\Alarm messages:If Event\Alarm messages are
important and must be reviewed as soon as possible, set scanning
to1 hour or Scan continuously.

•  Repository: Use the options in Repository tab of the General Setup dialog box
(Figure 2- 24) to configure the TSMWin32 storage management system. You can
speci fy or create the repository drive, path, and folder name, the maximum number
of days for which to store data, and the minimum amount of free space to maintain.
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Figure 2- 24. General Setup dialog box
Repository tab

•  Installation Directory: Enter the drive, path. and folder name in which to
store TSMWin32 repository information. Enter an existing folder path and
name, or create a new folder by typing a new folder name. If you enter the
name of a folder that does not exist, TSMWin32 asks you if you want to
create a new folder of that name (Error! Reference source not found.).
Click Yes to create the folder or click No to close the dialog box and enter
another folder name.

Figure 2- 25. Create directory confirmation message

•  Delete data files after (n) Days: Enter the maximum number of days for
TSMWin32 to store phase, 24 hr MTIE, TDEV, frequency, and historical
MTIE data.

•  Delete events after (n) Days: Enter the maximum number of days for
TSMWin32 to store event history data.

•  Minimum free space: TSMWin32 stores the data gathered by scanning up to
a maximum number of days or until a minimum amount of hard drive space
is reached. When storage management constraints are reached, TSMWin32
removed data using First-In-First-Out methods, i.e., the oldest data is
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removed to make room for currently gathered data. Enter the minimum
number of megabytes of free hard drive space to reserve on the hard disk,
i.e., the minimum amount of free space on the drive to maintain. When this
threshold is reached, TSMWin32 begins deleting data.

•  Terminal: In the Terminal tab of the General Setup dialog box (Figure 2- 26), set the
terminal timeout time, the amount of time for which a terminal connection may
remain inactive before TSMWin32 terminates the connection. Enter the timeout
amount in the format H:MM. The default timeout is 5 minutes, specifi ed as 5:00.

Figure 2- 26. General Setup dialog box
Terminal tab

Note: The terminal mode allows you to perform TSG configuration, such as setting
MTIE Alarm Limits. However, keep in mind that scanning does not gather data for a
TSG connected in terminal mode. The terminal timeout settings default to five
minutes before timing out, to ensure that the terminal connection is not inadvertently
left open.

2.3.9.2 TSGs . . .

Choose TSGs . . . on the Setup menu to open the TSG Setup dialog box (Figure 2- 27). The
tabs in this dialog box present options for defining and configuring any number of TSGs,
inputs, and connection settings.

Click the tab title to bring the tab to the front of the dialog box.

The options in the tabs apply to the TSG named in the TSG list box at the top of the dialog
box.

To modify a defined TSG:

•  Select a TSG from the TSG list.

•  Click a tab title to display the tab and make the desired changes.
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•  Click OK or Apply to apply the changes (or click Cancel to close the dialog box
without making changes).

Figure 2- 27. TSG Setup dialog box
General tab

To define a new TSG:

•  In the General tab, enter a new TSG name.

•  Click Apply. TSMWin32 adds the new TSG name to the list.

To configure a defined TSG.

•  Select the TSG to configure. Click the TSG list to display the available TSGs.

•  Click on the General tab and specify the general settings (below).

To enter information in the TSG Setup dialog box tabs:

•  General: Use the options on the General tab of the TSG Setup dialog box to specify
general TSG settings:

•  TSG Name: Enter a new TSG name. The default name for a new TSG is
TSG ###, where ### is a number between 1 and 999. You may change this
name to a more meaningful name, perhaps describing the location of the
TSG, for example, AustinTX TSG. After you enter a new name, click Apply
to change the TSG name in the top of the dialog box to the one just entered.

•  Enabled: Mark this checkbox to enable data gathering for the TSG. If a
TSG is taken offline or does not require data gathering, unmark the check
box to stop data gathering for the selected TSG.

•  Set TSG's time to PC's time: Click the check box to use the computer time
setting to set the TSG time, allowing TSGs a common time stamp.



12778458-002-2 Rev. F ▼▼▼▼ D ATUM-Austron

2-24 ▲▲▲▲ U sing TSMW in32 TSMW in32 User Guide

Remember that since data is time stamped using TSG time, setting all
connect ed TSGs to the same time ensures proper data correl ation.

•  User Name: Enter an ADMIN user name. If users have been created for the
TSG, TSMWin32 must log into the TSG at the ADMIN level using the
ADMIN user name and password. If no users have been assigned to the
TSG, the User Name and Password fields may be left empty.

•  Password: Enter an ADMIN password. If users have been created for the
TSG, TSMWin32 must log into the TSG at the ADMIN level using the
ADMIN user name and password. If no users have been assigned to the
TSG, the User Name and Password field may be left empty.

•  New TSG: Click the New TSG button to create a new TSG name when a
new TSG is added to the system. TSMWin32 assigns a new TSG name in
the format TSG ###, where ### is the next available TSG number between
1 and 999, and adds the TSG to the list of configurable TSGs.

•  Delete TSG: Click the Delete TSG button to delete the selected TSG name
from the TSG list.

•  Inputs: Use the options in the Inputs tab of the TSG Setup dialog box (Figure 2- 28)
to define which inputs to use and to assign meaningful names to each; use the
scrollbar to scroll from Input 1.1 to Input 4.3. For each input, specify:

Figure 2- 28. TSG Setup dialog box
Input tab

•  Enabled: Enable an input by placing a check mark beside the input. Each
input can be individually enabled for dat a gathering. This is similar to the
TSG Enable check box, except that data gathering is done on an Input-by-
Input basis. All inputs are disabled by default.
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•  Name: Enter an optional name for the input. To enter a name, enable the
input (above). When you enable an input, the name field is activated, giving
you with the option to assign a meaningful name to the input (for example,
the source of that input, such as Dallas PRR10 #1).

Click Apply or OK to save the changes (or click Cancel to close the dialog box
without saving changes).

TSMWin32 supports the two styles of input module available for each TSG:

•  Single port input modules (both 1 nS and 54 nS).

•  Three port modules.

•  Connection: Use the options in the Connection tab of the TSG Setup dialog box
(Figure 2- 29) to define which communications port to connect to the selected TSG.
Speci fy the a connection type, port, IP address, phone number, and modem
initialization string for the selected TSG.

Figure 2- 29. TSG Setup dialog box
Connection tab

You can connect up to 999 TSGs to a single communications port that has been
defined by the operating system. TSMWin32 can use one or more communications
ports to "talk" to multiple TSGs. As an example, using a 16-port EIA-232 card, you
can configure the system with direct connections to co-located TSGs, modem
connections to remote TSGs, and X.25 connections to still other remote TSGs. All
the connections can be made using a single computer (assuming that all the hardware
uses Windows 95/98/NT-compatible device drivers).

•  Connection Type: Select the connection type from the list: Direct Serial,
Modem, X.25 PAD, TCP/IP. For Modem or X.25 PAD connections, you
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must specify a Phone# or PAD ID to allow the modem or PAD to make the
connection; for TCP/IP connections, you must specify an IP Address.

•  Port: Select the communications port that TSMWin32 will use to connect to
the selected TSG. You may use a single port to connect to many TSGs.

•  IP Address: Enter the IP address.

•  Phone#: Enter the phone number or (for X.25 network connections) the
PAD ID required to make the connection.

•  Modem Init String: Enter the modem initialization string. Some modems
require additional setup (initialization) strings to be sent to them for proper
operation. TSMWin32 automatically re-initializes modems before
attempting to make the connection.

Note: Only connection options appropriate to the connection type are active.

•  EIA-232: Use the options on the EIA-232 tab of the TSG Setup dialog box (Figure 2-
30) to configure communications parameters for a computer with an EIA-232 serial
card. To do this, you must know the communications settings for each TSG before
starting.

Figure 2- 30. TSG Setup dialog box
EIA-232 tab

TSMWin32 connects directly to a TSG setup using factory default settings unless
you specify other communications settings in this tab. The suggested parameters are
9600-8-N-1 (baud = 9600, Data bits = 8, parity mode = None, Stop bits = 1).
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•  Baud Rate: Select the baud rate from the list. The default setting is 9600. If
a large number of TSGs are connected to a single system, we suggest
setting all TSGs and TSMWin32 to communicate at 19200 baud.

•  Parity Mode: Select the parity mode from the list. The default setting is
None. We recommend setting parity mode for very limited data validation.

•  Data Bits: Select the number of data bits (data word length) from the list.
The default setting is 8.

•  Flow Control: Select the flow control method from the list. The default
setting is Off.

•  Stop Bits: Select the number of stop bits from the list. The default setting
is 1.

•  Timeout (secs): Enter a timeout setting in the format SS.00 where SS is the
number of seconds, and 00 is hundredths of seconds that can elapse before a
timeout occurs. When TSMWin32 sends a message and does not receive a
response within the amount of time specified, TSMWin32 closes the
connection.

After making the configuration changes and applying them to all the TSGs, you are ready to
veri fy the connection to a selected TSG:

1. Choose Terminal from the File menu (or press the Terminal toolbar button   ) to

open the Terminal window (Figure 2- 31).

Figure 2- 31. T erminal dialog box

2. Click the TSG list to display the available TSGs. Click the TSG to which to connect.

3. Click Connect to begin the connection.

4. The TSG may respond with a login prompt. Enter the login and password if
prompted to complete the connection.

5. Click Disconnect to disconnect from the selected TSG. Repeat these steps for each
TSG to which you wish to connect.

6. When you are finished making connections, click Disconnect to break the
connection, then click Done to close the Terminal window.
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Note: If no activity is detected for the TSG, the Terminal window disconnects automatically
after the speci fi ed terminal timeout period. For more information about specifying the timeout
period, see Paragraphs 2.3.9.1 and 2.3.9.2.

2.3.10 Help Menu

2.3.10.1 Help Topics . . .

Choose Help Topics . . . from the Help menu (or click the Help toolbar button  ) to open

the Help Topics (Figure 2- 32) and view a table of contents to an indexed, searchable dat abase
of Help topics.

Figure 2- 32. TSMWin32 Help Contents Page

To view a Help topic (Figure 2- 33), double-click on the book icon to display a list of the
available topics. Double click on the topic (or click Display).

Use the Help menu commands open, print, copy, annotate, bookmark, customize, or exit
Help:

•  File: Use the commands on the File menu to open a Help file, print the active topic,
or exit the Help window.

•  Edit: Use the commands on the Edit menu to copy the contents of the Help window
or open the Annotate dialog box and enter text.

•  Bookmark: Use the commands on the Bookmark menu to define a Help bookmark.
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•  Options: Use the commands on the Options menu to customize the appearance and
behavior of Help windows. You can set options to:

•  Keep Help on Top: Select behavior for the Help window. Choose Default,
On Top, or Not on Top.

•  Display History Window . . .: Display the Windows Help History window,
and select a recent Help topic to open.

•  Font: Select the font size to use for displaying Help topics. Choose Small,
Normal, or Large.

•  Use System Colors: Select this option to change the colors used by the Help
windows to those specifi ed in your system settings.

•  Help: View the Windows Help Viewer version number and the TSMWin32 Help
copyright information.

Figure 2- 33. Help topic

To navigate in Help, use the buttons at the top of the Help topic window:

•  Find: Open the Find tab of the Help Topics window.

•  Help Topics: Open the Help Topics window (Figure 2- 32).

•  Back: Open the last topic visited.

•  Print: Print the current topic.

•  Options: Set Help appearance and behavior options.

•  >> (Next topic): Go to the next topic in the sequence.

•  << (Previous topic): Go to the previous topic in the sequence.

To search the Help topics database:

1. Click the Find tab in the Help Topics window (Figure 2- 32).

2. Enter a search string in the text box labeled Type the word(s) you want to find.
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3. To further limit your search (i.e., to reduce the number of topics displayed), make a
selection from the list labeled Select some matching words to narrow your search.

4. To display a topic, double-click a topic in the list (or click on a topic, then click
Display).

2.3.10.2 About TSMWin32 . . .

Choose About TSMWin32 . . . from the Help menu to display the TSMWin32 About dialog
box and view the product name, version number, firmware version, and copyright
information.



12778458-002-2 Rev. F ▼▼▼▼ D ATUM-Austron

TSMW in32 User Guide Using Au sGraph to View Outputs ▲▲▲▲ 3-1

3 Using AusGraph to View Outputs

3.1 In This Chapter . . .

! Overview of AusGraph and TSMWin32 Outputs

! AusGraph Menus

3.2 Overview of AusGraph and TSMWin32 Outputs
TSMWin32 features an embedded graphics application, AusGraph, for presenting graphical
data. AusGraph allows you to configure the display of data and to print the results. For
example, the figure below, shows a Phase graph with two inputs, with the View menu options
Color, Title, Grid, Y Axis, X Axis, and Legend selected.

Figure 3- 1. Phase data graph

3.2.1 Launching AusGraph

When you choose any option on the TSMWin32 Graph menu, the dialog box features options
for selecting and configuring the input data to graph. Click the Graph button to launch
AusGraph and display the data.
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For example, to launch AusGraph and display the phase data graph:

1. Click Phase on the Graph menu.

2. In the Select data for Phase Graph dialog box:

•  Choose a TSG from the list (click on the TSG list to display the available
TSGs).

•  Chose an input from the list (click on the Input list to display the available
inputs).

•  Enter the duration for the data to be graphed: enter a Start Date, Start Time,
Stop Date, and Stop Time.

3. Click the Graph button to launch AusGraph and display the data as a plot.

3.3 AusGraph Menus
Use the commands on the AusGraph menus to configure the display and scale of TSMWin32
data plots and graphs, and to print graphs.

3.3.1 Graph Menu

3.3.1.1 Print . . .

Choose Print from the Graph menu (or press CTRL + P) to open the Print dialog box for your
printer and set standard Windows printer options to use in printing the graph.

For best printing of graphs, select Landscape in the printer properties Orientation options.
The location of this option varies according to the printer selected.

3.3.1.2 Print Setup . . .

Choose Print Setup from the Graph menu to open the Print Setup dialog box for your printer
and choose standard Windows printer setup options for printing the graph.

3.3.1.3 Close

Choose Close from the Graph menu (or press ALT + F4) to exit AusGraph.

Note: Closing AusGraph does not close TSMWin32.
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3.3.1.4 About AusGraph . . .

Choose About from the Graph menu to open the AusGraph About dialog box (Figure 3- 2)
and view AusGraph version and copyright information.

Figure 3- 2. About AusGraph dialog box

3.3.2 View Menu

Use the commands on the View menu to customize the appearance of the graph and to select
an input.

The commands on the View menu act as switches, changing the settings to their "on"
(marked) or "off" (unmarked) states. For example, when there is a check mark beside the Title
command, the AusGraph displays the graph title. To display the graph without the graph title,
click the Title command again to remove the check mark.

3.3.2.1 Color

Choose Color from the View menu to display graph inputs in color.

3.3.2.2 Black & White

Choose Black & White from the View menu to display the graph in monochrome format, with
each input displayed as a different line style.

3.3.2.3 Title

Choose Title from the View menu to toggle graph titles on or off.

3.3.2.4 Grid

Choose Grid from the View menu to toggle the graph grid on or off.

3.3.2.5 Y Axi s

Choose Y Axis from the View menu to toggle the Y Axis of the graph on or off.
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3.3.2.6 X Axis

Choose X Axis from the View menu to toggle the X Axis of the graph on or off.

3.3.2.7 Legend

Choose Legend from the View menu to toggle graph legends on or off. You can select the
legend and move it on the graph display so that all data is visible.

3.3.2.8 Input Plot List

AusGraph displays the selected inputs shown on the selected graph at the bottom of the View
menu. Click an input name to toggle the display of that input.

3.3.3 Scale Menu

Use the commands on the Scale menu to select the scaling units for the graph. The contents of
the Scale menu:

•  Change according to the type of data displayed. For example, if the graph displays
frequency data, the scale options include Picosec/Sec and Nanosec/Sec; i f the graph
displays TDEV data, the only scale option offered is Nanoseconds.

•  Act as interdependent option buttons, allowing you to choose only one option at a
time from the group.

To view graphed data using more than one scaling unit, create a new graph for each new
scaling unit.

3.3.3.1 Picosec/Sec

Choose Picosec/Sec from the Scale menu to set the Y Axis scale to be displayed in
picoseconds or seconds.

3.3.3.2 Nanosec/Sec

Choose Nanosec/Sec from the Scale menu to set the Y Axis scale to be displayed in
nanoseconds or seconds.

3.3.3.3 Nanoseconds

Choose Nanoseconds from the Scale menu to set the Y Axis scale to be displayed in
nanoseconds.

3.3.3.4 DS1 Unit Intervals

Choose DS1 Unit Intervals from the Scale menu to set the Y Axis scale to be displayed in
fractional DS1 unit intervals. 648 nS is one unit interval.
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3.3.3.5 E1 Unit Intervals

Choose E1 Unit Intervals on the Scale menu to set the Y Axis scale to be displayed in
fractional E1 unit intervals. 488 nS is one unit interval.

3.3.3.6 Seconds

Choose Seconds from the Scale menu to set the X Axis scale to be displayed in seconds.

3.3.3.7 Minutes

Choose Minutes from the Scale menu to set the X Axis scale to be displayed in minutes.

3.3.3.8 Hours

Choose Hours from the Scale menu to set the X Axis scale to be displayed in hours.

3.3.3.9 Days

Choose Days from the Scale menu to set the X Axis scale to be displayed in hours
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4 Communications Ports and Modem
Setup

4.1 In This Chapter . . .

! Setting Up TSG Communications Ports

! Setting Up Modems

4.2 Setting Up TSG Communications Ports
The communications port of a connect ed TSG can be set up in any of several ways.

In determining the communications port setup method, consider the type of connection being
used to get information from the TSG. TSMWin32 allows you to specify Direct Serial,
Modem, X.25 PAD, or TCP/IP connections.

TSGs arrive from the factory with both serial ports ready for direct connections. Before
connecting, however, perform the following steps:

•  Veri fy the TSG jumper settings: remove the CPU card from the TSG and compare
the settings to those listed in Table 4- 1. TSG Communications Ports Setup.

Table 4- 1. TSG Communications Ports Setup

Direct Connection Modem Connection

Comm A Comm B Comm A Comm B

W11 1-2, 3- 4, 5- 6 W9 1-2, 3- 4, 5- 6 W11 1-2, 3- 4, 5- 6 W9 1-2, 3- 4, 5- 6

W7 1-2 W8 1-2 W7 3-4 W8 3-4

W13 2-4 W16 2-4 W13 1-2 W16 1-2

W14 1-2, 3- 4 W15 1-2, 3- 4 W14 1-3, 2- 4 W15 1-3, 2- 4

•  You must also connect to the TSG and issue the COM commands to set the
following (the options allow four possible combinations):

•  Set the communications port to A or B.
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•  Set the baud rate to 9600 or 19200. Although TSMWin32 is configured by
default to use the 9600 baud rate, the program can communicate to each
TSG at 9600 or 19200 baud.

Example: COM B BAUD 19200

4.3 Setting Up Modems
Modems must use these settings to connect to a TSG. The modem must also be able to save
the settings to the NVRAM of the modem.

1. Turn off the echo (E0).

2. Turn off the modem responses (Q1).

3. Set Auto Answer to 1 (S0=1).

4. Set the modem to TSG connection speed at 9600 (S37=9 and N0 on some modems).

5. Store these settings in NVRAM in case of power loss.

Note: Because modem standards vary greatly, for best performance, Austron urges you to use
only Hayes-compatible modems. In fact, if you wish, Austron can provide you with a "plug-
and-play" modem that is set up and ready to connect.

4.4 Estimating Hard Disk Space for 30 days of Data
The amount of hard disk space required for 30 days of TSG monitoring is of course dependent
upon the TSG configuration, and the number of TSGs that are connected to the system.

Here are some guidelines for estimating the required storage space for your configuration:

•  Every TSG (shelf) defined requires 2K bytes per day of dat a storage space.

•  Every input (channel) defined requires 10K bytes per day of data storage space.

•  If there are three TSGs, the first having four inputs, the second having two inputs,
and the third having one input, you can calculate the required hard disk space for 30
days of data storage thus:
(3*2k + ((4*10K) + (2*10K) + (1*10k)))*30 = 2.28 MB of total hard disk space.
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5 Glossary of Terms

alarm messages

Incoming alarm conditions and notifications of new alarms are displayed in the Alarm
window. Alarm information is parsed from the event data gathered from each TSG. Each
alarm consists of (1) the TSG unit ID, (2) the alarm timestamp, and (3) the alarm description
(including description of alarm severity level, whether critical, major, or minor).

AusGraph

Embedded graphics application for presenting and configuring the display of graphical data in
TSMWin32.

Auto-Scan

TSMWin32 setting which scans all connected TSGs continuously, i.e., automatically
beginning a new scan sequence at the preset time interval. When continuous scanning is set
with this option, Auto-Scan Disabled must be selected to stop the scan.

baud rate

Speed at which telecommunicated data is transmitted, measured in data interval time slots per
second. Elementary coding provides one bit per baud, and higher level coding enables
multiple bits to be transmitted per baud.

carrier

The frequency exchanged by modems used to transmit and receive data.

channel

In a communications system, the part that connects a data source to a data sink.

disconnect

To "hang up" or break the connection.

DS1 unit intervals

One baud time slot at the DS1 rate of 1.5444 megabaud per second = 648 ns.
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E1 unit intervals

One baud time slot at the E1 rate of 2.048 megabaud per second = 488 ns.

EIA-232

Another name for the RS-232C interface, a standard interface between peripherals and
microcomputers, and between modems and terminals.

error correction

Communications protocol which allows errors to be corected by the receiver once the receiver
determines that an error exists.

error detection

Communications protocol which allows the receiver to determine that the received dat a bits
contain one or more errors.

Ethernet

Network access method developed by Digital Equipment Corporation, Intel, and Xerox in the
early 1970s; the most widely used local-area network technology.

firmware

Software that has been copied to integrated circuits.

First In - First Out

Method of storing and retrieving items from a list, table, or stack, so that the first element
stored is the first one retrieved. TSMWin32 utilizes this method for removing data from the
TSMWin32 repository, removing oldest data first, as required, to make space for new dat a.

frequency

Frequency data (fractional frequency offset ) is presented as Delta F/F data graphed as a
function of a selected duration, scaled in picoseconds per second or nanoseconds per second.

input

In a channel, a point that accepts data.

IP address

Internet Protocol address. 32-bit number that identifies each sender or receiver of information
that is sent in packets across the Internet.

Internet Protocol (IP)

The primary network layer protocol for TCP/IP protocol suite; the most widely used network
protocol.
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legends

The graph legend box provides information which describes or identifies the graphed data.

modem

MOdulator-DEModulator. A device which provides communications capabilities between
computer equipment over common telephone facilities.

modem initialization string

Initializes the modem by sending to it a series or "string" of commands, typically Hayes
commands, which configure the modem's options for error correction, data compression, flow
control, and other parameters.

MTIE

Maximum Time Interval Error. For more information, refer to ANSI T1.101.

nanoseconds

One-billionth of a second (also called a millimicrosecond).

network element (NE)

In integrated services digital networks, a network element (NE) or piece of tele-
communications equipment used in the signal path of a telecommunications system, that
provides support or services to the user, for example, a SONET add-drop multiplexer.

PAD ID

Packet assembler/disassembler (PAD), a functional unit that enables data terminal equipment
not equiped for packet switching to access a packet-switched network.

parity

An error-detection scheme which uses an extra "checking bit," also called the parity bit, to
allow the receiver to check the received data for errors. The value of the parity bit is set so
that the sum of the data bits and the parity bit is always either even (for even parity) or odd
(for odd parity).

parity mode

Modem setting which allows for automatic error detection by using checking bits added to a
byte, charact er, or word to ensure that there is always either an even number or odd number of
bits, according to the logic of the system. If hardware failure causes a bit to be lost in
transmission, its loss can be detected by checking the parity.

PC time

The time-of-day and date setting for the operating system of the computer.
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performance mask

An array of performance values for the data type.

repository

The portion of the file system designated as the storage location for TSMWin32 data and
configuration data.

scanning

Monitoring one or more connected TSGs for transmission information.

serial card (EIA-232)

Interface card used between peripherals and microcomputers, modems, and terminals.

serial port

A common connection on a personal computer used to attach devices such as modems and
other peripherals, and through which data are transmitted and received one bit at a time.

TCP/IP

Transmission Control Protocol/Internet Protocol, a networking protocol with ability to
connect disparat e hosts.

TDEV

Time Deviation. For more information, see ANSI T1.101.

terminal mode

TSMWin32 mode in which information can be sent and received over a communications
channel.

timeout

Amount of time for which a terminal connection may remain inactive before TSMWin32
terminates the connection.

TSG

Timing Signal Generator.

TSMWin32.CFG

The TSMWin32 configuration file, containing the stored configuration values for maing
connections, gathering data: data storage and retri eval, TSGs, inputs, duration, etc.

user name

The user name required for logging in to a network connection.
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